02 / 04 · Technische Dokumentation
Filter und BIRD-Funktionen
Importfilter der Routeserver in der Reihenfolge der Konfiguration und die aktiven BIRD-Funktionen.
Importfilter#
Reihenfolge der Prüfungen beim Import, so wie sie in der Konfiguration steht. Trifft ein Punkt zu, wird die Route nicht weitergegeben, bleibt aber im Looking Glass mit Begründung sichtbar (Community 214591:1101:<Grund>, siehe BGP Communities).
| Prüfung | Regel |
|---|---|
| Prefixlänge IPv4 | länger als /24 wird verworfen |
| Prefixlänge IPv6 | länger als /48 wird verworfen |
| Bogons / Martians | RFC-1918, Dokumentations-, Link-Local-, Multicast- und sonstige reservierte Netze; für IPv6 zusätzlich ULA, 6bone, ungültige 6to4 |
| AS-Pfad leer | verworfen |
| Erste AS im Pfad | muss die ASN des Members sein |
| Next Hop | muss eine Peering-Adresse des Members sein; ein anderer Router desselben Members ist erlaubt |
| Transit-ASNs im Pfad | verworfen bei 174, 701, 1299, 2914, 3257, 3320, 3356, 3491, 4134, 5511, 6453, 6461, 6762, 6830, 7018 |
| AS-Pfad zu lang | mehr als 64 Einträge |
| RPKI | invalid wird verworfen; valid und unknown werden weitergegeben und markiert |
| IRRDB | Prefix und Origin-AS müssen im AS-SET des Members stehen (Quelle: RADB, RIPE, ARIN je nach Member); Aktualisierung alle sechs Stunden |
Weitere Funktionen#
Alle aktiv:
- RFC 8092 Large Communities zur Steuerung (siehe BGP Communities). Klassische Communities sind für die Steuerung nicht möglich, weil AS214591 eine 32-bit-ASN ist.
- RFC 8326 Graceful Shutdown: Routen mit der Community
65535:0bekommen Local Preference 0. Member können so Wartungen ankündigen, ohne die Session abzubauen. - Communities werden durchgereicht: Der Routeserver interpretiert die wohlbekannten Communities nicht selbst (
interpret communities off), Member sehen also NO_EXPORT und Co. so, wie der Absender sie gesetzt hat. Einzige Ausnahme: alle Communities mit 214591 als erstem Teil werden beim Export entfernt. - Eigene Tabelle je Member: Jede Session hat ihre eigene Routing-Tabelle, Filterentscheidungen sind im Looking Glass je Peer nachvollziehbar.
- Verzögerter Sessionstart nach einem Neustart des Routeservers, damit die RPKI-Daten vor der ersten Route vorliegen.
Looking Glass: manager.frankonix.net/lg
Technische Fragen: support@frankonix.net
Stand: November 2026